Wanhao out of action

Hi folks,

As the Wanhao printer has been failing to feed properly lately (being clicky, stringy feed rate , stopping feeding at all occasionally), I have taken it out of action.

I plan to up/side grade its firmware to Marlin later today (Thurs 7th), if that doesn’t help, then I will likely replace the extruder completely with the ex-extruder of my Prusa MK2S (which I am upgrading to the MK3 extruder).

Any thoughts / hints / ideas, yell now!

Jess

Still in progress, annoyingly. Arduino programming is a pain in the butt. More poking happening tonight (Wednesday)

Jess

Soo… Wednesday evening’s attempt didn’t go well either, I think I may have done something to the electronics :frowning:

Next ideas / attempts:

Any thoughts / preferences? Multiple simultaneous options are available…

sigh

Jess

So whats the state of the current board? Is it broken beyond repair/undo due to failed flashing attempts? Or does it still (maybe) have the original firmware on it? Will it still work “as well as it used to” if everything just gets plugged back in? (because the printer did used to work - Nick printed loads of stuff on it)

On the “buy new but same electronics and try to flash” option - this only seems to makes sense if you know what has gone wrong trying to flash the current board - do you know what this is so you can avoid doing it on a new board?

Have you given up trying to flash the existing board? I have a dedicated ISP programmer that I could try re-flashing the current board with and see if I have any more success, but I don’t want to mess things up if you are still in the middle of trying things.

I’m fairly sure the flashing attempts have wiped the previous firmware… and it now seems to be in a state where it can’t be flashed …

I’ve given up with that board, feel free to have a try. We were using Nat’s dedicated ISP programmer on Wed night, to no success.

Okay, might have a go over the weekend if I get chance.

I don’t know enough about the technical details of the options to have a preference but… I’d contribute to a pledge if the result would be a usable printer somehow?! An interim loan would be nice too for the same reason. :slight_smile:

1 Like

I had no luck trying to flash it this morning :frowning:

It doesn’t seem to be reporting a valid device signature (just returns 0x000000). Which implies that maybe the fuses are set wrong (which could be the result of an incorrect flashing attempt), though this should be fixable by just reflashing, but that doesn’t work, which kind of implies something else is wrong with the board or chip.

Not really sure what a good next step would be

hmm, could check if this is the issue:

https://reprap.org/wiki/Melzi#Can.27t_connect_to_the_Melzi_.28FTDI_driver_problem.29

Also for fuse poking: https://reprap.org/forum/read.php?1,691455

I doubt its the FTDI problem as that wouldn’t stop you being able to program it using an ISP programmer - it would just stop the USB port on the Meltzi board working.

Fuses yeah, I had a play on the command line on Sunday, but didn’t get anywhere. I even made a half arsed attempt at applying an external clock to try and get it to program, but it didn’t help. (and I’m not sure I did it right)

I wonder if maybe you tried to flash the bootloader without selecting the right board (the Sanguino) and maybe that caused it to change some fuses that have disabled the external oscillator. Though that kind of doesn’t make a lot of sense either because I expect any arduino type board to be using the internal oscillator or an external crystal. So it should have been left running off the external crystal, or the internal oscillator - in either case you should still be able to reprogram it…

Reading this page (http://forum.arduino.cc/index.php/topic,51819.0.html) it looks like maybe not supplying enough power to the board being programmed could be an issue as well - though I did check voltages on the Meltzi board and they were reading 5V.

Yesterday evening I brought in my Prusa boxmodel, we had some fun setting up ,Y-idler broke during transport, so replaced that and the Y… whatever the bit is called that clamps the ends of the Y-belt … Much thanks to all who pitched in to help with that.

It printed its first ever PLA!

I will do another test print of useful size today, then add the cura ini to the octoprint slicer on the Pi, and give out a link to it.

I am ordering another Melzi board for the Wanhao, yell now if you think that’s a bad idea.

Jess

Melzi ordered, I think… tho the site has a weird way of saying “order finished”

Did give us much chance to chip in there! But it sounds like the right plan anyway. :smile:

We could also look at trying to make the Prusa I2 work again. I can’t remember what was really wrong with it, other than needing some tlc.

Oops, sorry, got carried away…

Matt M said yesterday, it was failing to move sideways… and/or having issues with the x-end stop? I don’t remember exactly…

Oh yeah, that sounds familiar. I think it was an endstop problem. i.e. thought the endstop was triggered so refused to move.

1 Like

Update,
Meltzi board didn’t have the bootloader on it, so I’ve flashed the bootloader, which means it is now reasonably easy to reflash via USB. Though please make sure you are using the correct board type (Sanguino with ATMega 1284P 16Mhz to avoid any more bricking :))
I’ve flashed the Marlin version from the thingiverse page. we have 10k resistors on the board. Will commit the code I used to github later - I had to invert the z-axis motor to make it go the right way.

I’ve also dismantled and cleaned out the hotend and extruder. The nozzle was pretty gunked up, so I swapped it for one that looked less gunked up. Also the tube that runs down the centre of the heaksink was gunky, so I’ve done my best to clear that out. To my mind, the nozzle and heatblock were assembled wrong, so I’ve fixed that - the Nozzle is now screwed tightly up against the heat block (it wasn’t before)

I’ve re-levelled the bed to account for slight the extruder geometry change.

A test print has come out reasonable, but only by upping the feed rate during the print. I guess because we don’t have the default Wanhao extruder we need to reconfigure the extruder steps per mm. No idea what this is right now, so I’m leaving this for the time being.

Temps seem to be reporting correctly. Printing at 205 for PLA seems okay-ish.

Still to do:

  • Configure Extruder steps / mm
  • Make part fan work
1 Like

I’ve reconfigured the extruder steps per mm and it prints better quality things now.

It still seems to click a bit, which implies something isn’t quite right with the feed. And I suspect if I leave it to cool down fully and print again in a few days it might just click away again. A workaround for this seems to be to heat up the hot end, retract the filament out and leave it hot for a few minutes, then feed the filament back in. At least that worked once.

It’s probably usable enough to work on Sunday.

The Wanhao has been poked several times since the beginning of the month - we need a better way to document things done to it / machines in the space…

Either way I believe it is now in a working state.

Also we are about to get a Prusa MK2, after a successful pledge drive (2nd hand, well cared for)